General (Solo II)

How do I re-pair my transmitter to my Solo II display?
-Hold down the – and + button both together on the display until you see [PAIRMODE] -You should now see “MAIN SENSOR” -Hold down middle button so ...
Why is my display is not showing any readings?
This could be because your main transmitter is out of range and is not in communication with the Display. You can try moving the display to a position whe...
How do I reset my display?
To reset, turn off your display and hold down all three buttons on the front and power it back on at the same time while pressing down on all three button...
Why is my display/energynote showing incorrect reading?
When the display loses signal with the meter the display shows the last known live load still on the screen. The cumulative totals will also fail to incre...
Why has my display turned off?
You have sleep mode enabled – the sleep mode can be edited under the [ADVANCED] configuration.
The readings on my Display do not match my meter.
Depending on whether you have a CT clip sensor or LED sensor this might be for a couple of reasons. Please see both below: LED Sensor With an LED sensor ...
How do I add a temperature sensor to my Display?
The Solo II uses an integrated temperature sensor. By default, this is represented as temperature sensor 1 on the display. If you choose to pair an additi...
How do I un-pair or remove a temperature sensor?
If you have paired the sensor to the wrong slot on the display (i.e overwriting [T1 SENSOR] when you did not mean to) you can un-pair it and re-pair it ag...
How can I see the signal strength to the external temperature sensor?
The signal strength for the sensors can be viewed on the Pairing screens.
Where can I get help on the Solo II Smart Plugs?
Currently Smart Plugs cannot be used with the PV version of the Solo II. Please visit our dedicated Smart Plug support page here if you have smart pl...